]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ffmpeg/ffmpeg_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ffmpeg / ffmpeg_cvs.bb
1 PV = "0.4.9-pre1+cvs-${CVSDATE}"
2 DESCRIPTION = "ffmpeg"
3 SECTION = "libs"
4 PRIORITY = "optional"
5 DEPENDS = "zlib libvorbis faac liba52 lame"
6 LICENSE = "GPL"
7 PR = "r1"
8 S = "${WORKDIR}/ffmpeg"
9 DEFAULT_PREFERENCE = "-1"
10
11 inherit autotools
12
13 SRC_URI = "cvs://anonymous@mplayerhq.hu/cvsroot/ffmpeg;module=ffmpeg \
14         file://configure.patch;patch=0 \
15         file://common.patch;patch=1 \
16         file://soname.patch;patch=1 \
17         "
18
19 TARGET_LDFLAGS_append = " -lm -la52 "
20
21 EXTRA_OECONF=" \
22         --enable-mp3lame \
23         --enable-vorbis \
24         --enable-faac \
25         --enable-a52 \
26         --enable-a52bin \
27         --enable-pp \
28 #       --enable-shared-pp \
29         --enable-shared \
30         --disable-amr_nb \
31         --enable-amr_nb-fixed \
32         --disable-amr_wb \
33         --enable-pthreads \
34         --enable-gpl \
35         --enable-zlib \
36         \
37         --disable-audio-beos \
38         --disable-v4l \
39         --disable-dv1394 \
40         --disable-debug \
41         --disable-ffserver \
42         --disable-ffplay \
43         \
44         --cross-prefix=${TARGET_PREFIX} \
45         --extra-cflags=\$(TARGET_CFLAGS) \
46         --extra-ldflags=\$(TARGET_LDFLAGS) \
47         --extra-libs=\$(TARGET_LDFLAGS) \
48         \
49         --cpu=${PACKAGE_ARCH} \
50         --prefix=${D}${prefix} \
51         --mandir=${D}${prefix}/share/man \
52 "
53
54 PACKAGES += "libavcodec libavcodec-dev libavformat libavformat-dev"
55 FILES_${PN} = "${bindir}"
56 FILES_${PN}-dev = "${includedir}"
57 FILES_libavcodec = "${libdir}/libavcodec*.so.*"
58 FILES_libavcodec-dev = "${libdir}/libavcodec*.so ${libdir}/libavcodec*.la ${libdir}/libavcodec*.a"
59 FILES_libavformat = "${libdir}/libavformat*.so.*"
60 FILES_libavformat-dev = "${libdir}/libavformat*.so ${libdir}/libavformat*.la ${libdir}/libavformat*.a"
61
62 # We do this because the install program is called with -s which causes it to call "strip" and it then mangles cross compiled stuff..
63 PATH_prepend="${CROSS_DIR}/${TARGET_SYS}/bin:"
64
65
66 do_configure_prepend() {
67         export CC="${CC}"
68 }
69
70 do_stage() {
71         oe_libinstall -a -so -C libavcodec libavcodec ${STAGING_LIBDIR}
72         oe_libinstall -a -so -C libavformat libavformat ${STAGING_LIBDIR}
73
74         install -d ${STAGING_INCDIR}/ffmpeg
75         install -m 0644 ${S}/libavcodec/avcodec.h ${STAGING_INCDIR}/ffmpeg/avcodec.h
76         install -m 0644 ${S}/libavcodec/common.h ${STAGING_INCDIR}/ffmpeg/common.h
77         install -m 0644 ${S}/libavcodec/rational.h ${STAGING_INCDIR}/ffmpeg/rational.h
78         install -m 0644 ${S}/libavformat/avformat.h ${STAGING_INCDIR}/ffmpeg/avformat.h
79         install -m 0644 ${S}/libavformat/avio.h ${STAGING_INCDIR}/ffmpeg/avio.h
80         install -m 0644 ${S}/libavformat/rtp.h ${STAGING_INCDIR}/ffmpeg/rtp.h
81         install -m 0644 ${S}/libavformat/rtsp.h ${STAGING_INCDIR}/ffmpeg/rtsp.h
82         install -m 0644 ${S}/libavformat/rtspcodes.h ${STAGING_INCDIR}/ffmpeg/rtspcodes.h
83 }