]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/flac/flac_1.1.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / flac / flac_1.1.0.bb
1 DESCRIPTION = "FLAC is a Free Lossless Audio Codec."
2 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
3 LICENSE = "BSD GPL"
4 SECTION = "libs"
5 DEPENDS = "libogg"
6 PR = "r2"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/flac/flac-${PV}.tar.gz \
9            file://disable-xmms-plugin.patch;patch=1 \
10            file://xmms.m4"
11 S = "${WORKDIR}/flac-${PV}"
12
13 inherit autotools
14
15 EXTRA_OECONF = "--disable-oggtest --disable-id3libtest \
16                 --with-ogg-libraries=${STAGING_LIBDIR} \
17                 --with-ogg-includes=${STAGING_INCDIR} \
18                 --without-xmms-prefix \
19                 --without-xmms-exec-prefix \
20                 --without-libiconv-prefix \
21                 --without-id3lib"
22
23 PACKAGES += "libflac libflac++ liboggflac liboggflac++"
24 FILES_${PN} = "${bindir}"
25 FILES_libflac = "${libdir}/libFLAC.so.*"
26 FILES_libflac++ = "${libdir}/libFLAC++.so.*"
27 FILES_liboggflac = "${libdir}/libOggFLAC.so.*"
28 FILES_liboggflac++ = "${libdir}/libOggFLAC++.so.*"
29
30 do_configure () {
31         install -d ${S}/m4
32         install -m 0644 ${WORKDIR}/xmms.m4 ${S}/m4/
33         autotools_do_configure
34 }
35
36 do_stage () {
37         install -d ${STAGING_DATADIR}/aclocal
38
39         oe_libinstall -a -so -C src/libOggFLAC libOggFLAC ${STAGING_LIBDIR}/
40         install -d ${STAGING_INCDIR}/OggFLAC
41         install -m 0644 ${S}/include/OggFLAC/export.h ${STAGING_INCDIR}/OggFLAC/export.h
42         install -m 0644 ${S}/include/OggFLAC/all.h ${STAGING_INCDIR}/OggFLAC/all.h
43         install -m 0644 ${S}/include/OggFLAC/stream_encoder.h ${STAGING_INCDIR}/OggFLAC/stream_encoder.h
44         install -m 0644 ${S}/include/OggFLAC/stream_decoder.h ${STAGING_INCDIR}/OggFLAC/stream_decoder.h
45         install -m 0644 ${S}/src/libOggFLAC/libOggFLAC.m4 ${STAGING_DATADIR}/aclocal/
46
47         oe_libinstall -a -so -C src/libFLAC libFLAC ${STAGING_LIBDIR}/
48         install -d ${STAGING_INCDIR}/FLAC
49         install -m 0644 ${S}/include/FLAC/export.h ${STAGING_INCDIR}/FLAC/export.h
50         install -m 0644 ${S}/include/FLAC/metadata.h ${STAGING_INCDIR}/FLAC/metadata.h
51         install -m 0644 ${S}/include/FLAC/all.h ${STAGING_INCDIR}/FLAC/all.h
52         install -m 0644 ${S}/include/FLAC/format.h ${STAGING_INCDIR}/FLAC/format.h
53         install -m 0644 ${S}/include/FLAC/stream_encoder.h ${STAGING_INCDIR}/FLAC/stream_encoder.h
54         install -m 0644 ${S}/include/FLAC/stream_decoder.h ${STAGING_INCDIR}/FLAC/stream_decoder.h
55         install -m 0644 ${S}/include/FLAC/ordinals.h ${STAGING_INCDIR}/FLAC/ordinals.h
56         install -m 0644 ${S}/include/FLAC/seekable_stream_encoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_encoder.h
57         install -m 0644 ${S}/include/FLAC/file_encoder.h ${STAGING_INCDIR}/FLAC/file_encoder.h
58         install -m 0644 ${S}/include/FLAC/seekable_stream_decoder.h ${STAGING_INCDIR}/FLAC/seekable_stream_decoder.h
59         install -m 0644 ${S}/include/FLAC/file_decoder.h ${STAGING_INCDIR}/FLAC/file_decoder.h
60         install -m 0644 ${S}/include/FLAC/assert.h ${STAGING_INCDIR}/FLAC/assert.h
61         install -m 0644 ${S}/src/libFLAC/libFLAC.m4 ${STAGING_DATADIR}/aclocal/
62
63         oe_libinstall -a -so -C src/libFLAC++ libFLAC++ ${STAGING_LIBDIR}/
64         install -d ${STAGING_INCDIR}/FLAC++
65         install -m 0644 ${S}/include/FLAC++/export.h ${STAGING_INCDIR}/FLAC++/export.h
66         install -m 0644 ${S}/include/FLAC++/metadata.h ${STAGING_INCDIR}/FLAC++/metadata.h
67         install -m 0644 ${S}/include/FLAC++/all.h ${STAGING_INCDIR}/FLAC++/all.h
68         install -m 0644 ${S}/include/FLAC++/encoder.h ${STAGING_INCDIR}/FLAC++/encoder.h
69         install -m 0644 ${S}/include/FLAC++/decoder.h ${STAGING_INCDIR}/FLAC++/decoder.h
70         install -m 0644 ${S}/src/libFLAC++/libFLAC++.m4 ${STAGING_DATADIR}/aclocal/
71
72         oe_libinstall -a -so -C src/libOggFLAC++ libOggFLAC++ ${STAGING_LIBDIR}/
73         install -d ${STAGING_INCDIR}/OggFLAC++
74         install -m 0644 ${S}/include/OggFLAC++/export.h ${STAGING_INCDIR}/OggFLAC++/export.h
75         install -m 0644 ${S}/include/OggFLAC++/all.h ${STAGING_INCDIR}/OggFLAC++/all.h
76         install -m 0644 ${S}/include/OggFLAC++/encoder.h ${STAGING_INCDIR}/OggFLAC++/encoder.h
77         install -m 0644 ${S}/include/OggFLAC++/decoder.h ${STAGING_INCDIR}/OggFLAC++/decoder.h
78         install -m 0644 ${S}/src/libOggFLAC++/libOggFLAC++.m4 ${STAGING_DATADIR}/aclocal/
79 }