]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/fltk/fltk_1.2+cvs20040806.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / fltk / fltk_1.2+cvs20040806.bb
1 DESCRIPTION = "FLTK is a cross-platform C++ GUI toolkit"
2 LICENSE ="LGPL"
3 HOMEPAGE = "http://www.fltk.org"
4 SECTION = "libs"
5 PRIORITY = "optional"
6 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
7 DEPENDS = "jpeg libpng zlib"
8 PR = "r2"
9
10 SRC_URI = "cvs://anonymous:@cvs.sourceforge.net/cvsroot/fltk;module=fltk;method=pserver;tag=v1_2;date=${@bb.data.getVar('PV', d, 1)[7:]} \
11            file://makefiles.patch;patch=1 \
12            file://autotools.patch;patch=1"
13 S="${WORKDIR}/fltk"
14
15 inherit autotools binconfig
16
17 do_configure_prepend() {
18         autoconf
19 }
20
21 FILES_${PN} = "${libdir}/lib*.so.*"
22 FILES_${PN}-dev += " ${bindir}/fltk-config"
23 LEAD_SONAME = "libfltk.so"
24
25 EXTRA_OECONF = "--enable-shared --disable-gl"
26
27 do_install () {
28         oe_runmake prefix="${D}${prefix}" \
29                 bindir="${D}${bindir}" \
30                 libdir="${D}${libdir}" \
31                 includedir="${D}${includedir}" \
32                 install
33 }
34
35 do_stage() {
36         oe_runmake install prefix=${STAGING_DIR} \
37                bindir=${STAGING_BINDIR} \
38                includedir=${STAGING_INCDIR} \
39                libdir=${STAGING_LIBDIR} \
40                datadir=${STAGING_DATADIR}
41 }
42
43 python populate_packages_prepend () {
44         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
45                 bb.data.setVar('PKG_${PN}', 'libfltk1.2', d)
46 }