]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/fortune-mod/fortune-mod_1.99.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / fortune-mod / fortune-mod_1.99.1.bb
1 DESCRIPTION = "Print a random, hopefully interesting, adage"
2 SECTION = "console/utils"
3 LICENSE = "GPL"
4 DEPENDS = "recode-native recode"
5 DEBV = "2"
6 PR = "r2"
7
8 SRC_URI = "${DEBIAN_MIRROR}/main/f/fortune-mod/fortune-mod_${PV}.orig.tar.gz \
9            ${DEBIAN_MIRROR}/main/f/fortune-mod/fortune-mod_${PV}-${DEBV}.diff.gz;patch=1"
10
11 PARALLEL_MAKE = ""
12 CFLAGS += '\$(DEFINES)'
13
14 do_configure() {
15         unset CC LD CFLAGS LDFLAGS
16         cd util && oe_runmake
17 }
18
19 do_install() {
20         oe_runmake install prefix="${D}"
21         mv -f ${D}/usr/games/fortune ${D}/${bindir}
22 }
23
24 FILES_${PN} += "${datadir}/games/fortunes/"