]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/freetype/freetype_2.1.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / freetype / freetype_2.1.8.bb
1 DESCRIPTION = "Freetype font rendering library"
2 SECTION = "libs"
3 LICENSE = "freetype"
4 PR = "r1"
5
6 SRC_URI = "${SOURCEFORGE_MIRROR}/freetype/freetype-${PV}.tar.bz2 \
7            file://configure.patch;patch=1"
8 S = "${WORKDIR}/freetype-${PV}"
9
10 inherit autotools pkgconfig binconfig
11
12 LIBTOOL = "${S}/builds/unix/${HOST_SYS}-libtool"
13 EXTRA_OEMAKE = "'LIBTOOL=${LIBTOOL}'"
14
15 do_configure() {
16         cd builds/unix
17         gnu-configize
18         aclocal -I .
19         autoconf
20         cd ${S}
21         oe_runconf
22 }
23
24 do_stage() {
25         autotools_stage_includes
26         oe_libinstall -so -a -C objs libfreetype ${STAGING_LIBDIR}
27 }
28
29 FILES_${PN} = "${libdir}/lib*.so.*"
30 FILES_${PN}-dev += "${bindir}"