]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/freeze/freeze.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / freeze / freeze.bb
1 # freeze finds all the bitbake files used by the stuff
2 # currently built in ${TMPDIR}/work and writes those
3 # files into frozen-bbfiles.conf, then it writes the
4 # directories containing the files into frozen-packages.conf
5 #
6 # The two files define (just) the BBFILES variable.
7 #
8 # The path names in the BBFILES variable are of the form:
9 #
10 # ${PKGDIR}/packages/directory/bbfile.bb
11 # ${PKGDIR}/packages/directory/*.bb
12 #
13 # as appropriate, directory is the sub-directory of 'packages'.
14 #
15 DESCRIPTION = "Freeze the bitbake files in the build"
16 MAINTAINER = "John Bowler <jbowler@acm.org>"
17 SECTION = "console/networking"
18 PRIORITY = "optional"
19 LICENSE = "MIT"
20 PR = "r1"
21
22 INHIBIT_DEFAULT_DEPS = "1"
23 PATCH_DEPENDS = ""
24 ALLOW_EMPTY = 1
25 PACKAGES = ""
26
27 SRC_URI = "file://freeze"
28
29 do_configure() {
30 }
31 do_compile() {
32 }
33 do_install() {
34 }
35 do_stage() {
36 }
37
38 do_build[nostamp] = 1
39 do_build() {
40         # export FROZEN_DIR=<place to write conf files>
41         # export PKGDIR=<location of openembedded package source>
42         # export DISTRO=<distro being frozen>
43         # freeze {directories}
44         set -x
45         if test -d "${PKGDIR}/packages"
46         then
47                 FROZEN_DIR="${FROZEN_DIR}" PKGDIR="${PKGDIR}" DISTRO="${DISTRO}" \
48                         sh "${WORKDIR}/freeze" "${TMPDIR}/work"
49         else
50                 oenote "\$PKGDIR/packages ($PKGDIR/packages) not found"
51                 oefatal "\$PKGDIR must be defined for freeze to work"
52         fi
53         set +x
54 }