]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/freeze/unfreeze.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / freeze / unfreeze.bb
1 # unfreeze undoes the work of freeze by making the frozen
2 # configuration fails empty (they just contain a comment).
3 #
4 DESCRIPTION = "Unfreeze the bitbake files in the build"
5 MAINTAINER = "John Bowler <jbowler@acm.org>"
6 SECTION = "console/networking"
7 PRIORITY = "optional"
8 LICENSE = "MIT"
9 PR = "r1"
10
11 INHIBIT_DEFAULT_DEPS = "1"
12 PATCH_DEPENDS = ""
13 ALLOW_EMPTY = 1
14 PACKAGES = ""
15
16 SRC_URI = "file://unfreeze"
17
18 do_configure() {
19 }
20 do_compile() {
21 }
22 do_install() {
23 }
24 do_stage() {
25 }
26
27 do_build[nostamp] = 1
28 do_build() {
29         # export FROZEN_DIR=<place to write conf files>
30         # export PKGDIR=<location of openembedded package source>
31         # unfreeze
32         set -x
33         # this is a sanity check:
34         if test -d "${PKGDIR}/packages"
35         then
36                 FROZEN_DIR="${FROZEN_DIR}" DISTRO="${DISTRO}" sh "${WORKDIR}/unfreeze"
37         else
38                 oenote "\$PKGDIR/packages ($PKGDIR/packages) not found"
39                 oefatal "\$PKGDIR must be defined for freeze/unfreeze to work"
40         fi
41         set +x
42 }