]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/frotz/frotz_2.42.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / frotz / frotz_2.42.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
3 HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
4 SECTION = "console/games"
5 DEPENDS = "ncurses"
6
7 SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
8         file://Makefile.patch;patch=1 "
9
10 do_configure() {
11         patch -N ${s}/ux_init.c < remove_root_restriction.patch || :
12         rm -f ${SourceTree}/frotz.conf
13 }
14
15 EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
16
17 do_compile() {
18         oe_runmake frotz
19         sed 's/^[a-z]/#&/' frotz.conf-big > frotz.conf;
20 }
21
22 do_install() {
23         oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
24 }