]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ftpd-topfield/ftpd-topfield_0.6.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ftpd-topfield / ftpd-topfield_0.6.1.bb
1 # This package builds the ftpd-topfield program
2 PR = "r0"
3 DESCRIPTION = "ftpd-topfield - FTP access to TopField PVR"
4 HOMEPAGE = "http://sourceforge.net/projects/puppy"
5 MAINTAINER = "NSLU2 Linux <www.nslu2-linux.org>"
6 SECTION = "net"
7 LICENSE = "MIT"
8
9 DEPENDS = "libusb"
10
11 SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=ftpd-topfield;tag=FTPD_TOPFIELD_0_6_1 \
12            cvs://anonymous@cvs.sourceforge.net/cvsroot/puppy;method=pserver;module=libtopfield;tag=FTPD_TOPFIELD_0_6_1 \
13            file://init"
14
15 # The source will end up in the subdirectory 'ftpd-topfield' - no release name
16 S = "${WORKDIR}/ftpd-topfield"
17 SL = "${WORKDIR}/libtopfield"
18
19 inherit update-rc.d
20
21 INITSCRIPT_NAME = "ftpd-topfield"
22 INITSCRIPT_PARAMS = "defaults"
23
24 # Just the one package at present
25 PACKAGES = "${PN}"
26
27 inherit autotools
28
29 do_compile() {
30         oe_runmake -C ${SL} libtopfield.a
31         oe_runmake LDLIBS="${LDFLAGS} -L ../libtopfield -ltopfield -lusb"
32 }
33
34 do_install() {
35         install -d ${D}${sbindir}
36         install -m 0755 ${S}/ftpd ${D}${sbindir}/ftpd-topfield
37         install -d ${D}${sysconfdir}/ ${D}${sysconfdir}/init.d
38         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/ftpd-topfield
39 }