]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gawk/gawk_3.1.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gawk / gawk_3.1.4.bb
1 LICENSE = "GPL"
2 SECTION = "interpreters"
3 DESCRIPTION = "A program that you can use to select particular records in a \
4 file and perform operations upon them."
5 PR = "r2"
6 PACKAGES += "gawk-common pgawk"
7 FILES_${PN} = "${bindir}/gawk* ${bindir}/igawk"
8 FILES_gawk-common += "${datadir}/awk ${libexecdir}/awk"
9 FILES_pgawk = "${bindir}/pgawk*"
10 RDEPENDS_gawk += "gawk-common"
11 RDEPENDS_pgawk += "gawk-common"
12
13 SRC_URI = "${GNU_MIRROR}/gawk/gawk-${PV}.tar.gz"
14
15 inherit autotools
16
17 do_configure_prepend () {
18         grep -E '^AC_DEFUN' m4/*.m4|grep -E '\(\[?(AM|AC)_'|xargs rm -f
19 }
20
21 pkg_postinst_${PN} () {
22         update-alternatives --install ${bindir}/awk awk gawk 100
23 }
24
25
26 pkg_prerm_${PN} () {
27         update-alternatives --remove awk gawk
28 }
29