]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gcc/gcc-cross_4.0.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gcc / gcc-cross_4.0.0.bb
1 include gcc_${PV}.bb
2 # path mangling, needed by the cross packaging
3 include gcc-paths-cross.inc
4 inherit cross
5 FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
6 # NOTE: split PR.  If the main .oe changes something that affects its *build*
7 # remember to increment this one too.
8 PR = "r1"
9
10 DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
11 PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
12
13 # cross build
14 include gcc3-build-cross.inc
15 # cross packaging
16 include gcc-package-cross.inc