]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gcc/gcc_3.4.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gcc / gcc_3.4.4.bb
1 PR = "r5"
2 DESCRIPTION = "The GNU cc and gcc C compilers."
3 HOMEPAGE = "http://www.gnu.org/software/gcc/"
4 SECTION = "devel"
5 LICENSE = "GPL"
6 MAINTAINER = "Gerald Britton <gbritton@doomcom.org>"
7
8 inherit autotools gettext
9
10 include gcc-package.inc
11
12 SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
13            file://gcc34-reverse-compare.patch;patch=1 \
14            file://gcc34-arm-ldm.patch;patch=1 \
15            file://gcc34-arm-ldm-peephole.patch;patch=1 \
16            file://gcc34-arm-tune.patch;patch=1 \
17            file://gcc-3.4.1-uclibc-100-conf.patch;patch=1 \
18            file://gcc-3.4.1-uclibc-200-locale.patch;patch=1 \
19            file://gcc-3.4.0-arm-lib1asm.patch;patch=1 \
20            file://gcc-3.4.0-arm-nolibfloat.patch;patch=1 \
21            file://gcc-3.4.0-arm-bigendian.patch;patch=1 \
22            file://gcc-3.4.0-arm-bigendian-uclibc.patch;patch=1 \
23            file://GCC3.4.0VisibilityPatch.diff;patch=1 \
24            file://15342.patch;patch=1 \
25            file://always-fixincperm.patch;patch=1"
26
27 SRC_URI += "file://gcc34-configure.in.patch;patch=1"
28 SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
29
30 include gcc3-build.inc