]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gchub/gchub-module_svn.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gchub / gchub-module_svn.bb
1 SECTION = "base"
2 PRIORITY = "optional"
3 DESCRIPTION = "Kernel module for the GameCube Hub input device"
4 DEPENDS = "virtual/kernel"
5 MAINTAINER = "Micah Dowty <micah@navi.cx>"
6 LICENSE = "GPL"
7 PV = "svn-${CVSDATE}"
8
9 SRC_URI = "svn://svn.navi.cx/misc/trunk/wasabi/devices;module=gchub;proto=http"
10
11 S = "${WORKDIR}/gchub/kernel"
12
13 inherit module
14
15 do_install() {
16         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb
17         install gchub.ko -m 0644 ${D}${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/usb/gchub.ko
18 }