]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gd/gd_2.0.21.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gd / gd_2.0.21.bb
1 SECTION = "libs"
2 LICENSE = "GD"
3 DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
4 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5 DEPENDS = "libpng jpeg zlib"
6
7 SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
8 S = "${WORKDIR}/gd-${PV}"
9
10 inherit autotools gettext
11
12 EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
13                   --with-png=${STAGING_LIBDIR}/.. \
14                   --with-jpeg=${STAGING_LIBDIR}/.. \
15                   --without-xpm"
16
17 headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
18            gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
19
20 do_stage () {
21         oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
22         for i in ${headers}; do
23                 install -m 0644 $i ${STAGING_INCDIR}/
24         done
25 }