]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gd/gd_2.0.22.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gd / gd_2.0.22.bb
1 SECTION = "libs"
2 LICENSE = "GD"
3 DESCRIPTION = "gd is a library used to create PNG, JPEG, or WBMP images."
4 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
5 DEPENDS = "libpng jpeg zlib"
6 PR = "r2"
7
8 SRC_URI = "http://www.boutell.com/gd/http/gd-${PV}.tar.gz"
9 S = "${WORKDIR}/gd-${PV}"
10
11 inherit autotools binconfig gettext
12
13 PACKAGES =+ "lib${PN}"
14 FILES_lib${PN} = "${libdir}/lib*.so.*"
15
16 EXTRA_OECONF += " --with-zlib=${STAGING_LIBDIR}/.. \
17                   --with-png=${STAGING_LIBDIR}/.. \
18                   --with-jpeg=${STAGING_LIBDIR}/.. \
19                   --without-xpm"
20
21 headers = "gd.h gdcache.h gd_io.h gdfx.h gdfontmb.h \
22            gdfontg.h gdfontl.h gdfonts.h gdfontt.h"
23
24 do_stage () {
25         oe_libinstall -so -a libgd ${STAGING_LIBDIR}/
26         for i in ${headers}; do
27                 install -m 0644 $i ${STAGING_INCDIR}/
28         done
29 }