]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gdb/gdb_6.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gdb / gdb_6.1.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "gdb - GNU debugger"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
6 DEPENDS = "ncurses readline"
7
8 PACKAGES =+ 'gdbserver '
9 FILES_gdbserver = '${bindir}/gdbserver'
10
11 inherit autotools gettext
12
13 SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
14            file://uclibc.patch;patch=1"
15
16 LDFLAGS_append = " -s"
17 export CC_FOR_BUILD = "${BUILD_CC}"
18 export CXX_FOR_BUILD = "${BUILD_CXX}"
19 export CPP_FOR_BUILD = "${BUILD_CPP}"
20 export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
21 export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
22 export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
23 export CFLAGS_append=" -L${STAGING_LIBDIR}"
24 EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
25
26 EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
27                 --with-curses --with-readline --disable-sim \
28                 --program-prefix=''"
29
30 do_configure () {
31 # override this function to avoid the autoconf/automake/aclocal/autoheader
32 # calls for now
33         gnu-configize
34         oe_runconf
35 }
36
37 do_install () {
38         make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
39         oe_runmake install \
40             'prefix=${D}${prefix}' 'exec_prefix=${D}${prefix}' 'bindir=${D}${bindir}' \
41             'sbindir=${D}${sbindir}' 'infodir=${D}${infodir}' 'libdir=${D}${libdir}' \
42             'mandir=${D}${mandir}' 'includedir=${D}${includedir}'
43         install -d ${D}${bindir}
44         install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
45 }
46
47 #
48 # patch description
49 #
50 # readline.patch:
51 #   gdb 5.3 provides its own readline source which tends to conflict with
52 #   readline package. we override readline included from gdb source
53 #   with packaged readline and fix up extern tilde_expand in gdb/defs.h
54 #