]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gdb/gdb_6.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gdb / gdb_6.2.bb
1 DESCRIPTION = "gdb - GNU debugger"
2 LICENSE="GPL"
3 SECTION = "devel"
4 PRIORITY = "optional"
5 PR = "r1"
6 MAINTAINER = "Pawel Osiczko <p.osiczko@tetrapyloctomy.org>"
7 DEPENDS = "ncurses readline"
8
9 PACKAGES =+ 'gdbserver '
10 FILES_gdbserver = '${bindir}/gdbserver'
11
12 inherit autotools gettext
13
14 SRC_URI = "${GNU_MIRROR}/gdb/gdb-${PV}.tar.gz \
15            file://uclibc.patch;patch=1"
16
17 LDFLAGS_append = " -s"
18 export CC_FOR_BUILD = "${BUILD_CC}"
19 export CXX_FOR_BUILD = "${BUILD_CXX}"
20 export CPP_FOR_BUILD = "${BUILD_CPP}"
21 export CFLAGS_FOR_BUILD = "${BUILD_CFLAGS}"
22 export CXXFLAGS_FOR_BUILD = "${BUILD_CXXFLAGS}"
23 export CPPFLAGS_FOR_BUILD = "${BUILD_CPPFLAGS}"
24 export CFLAGS_append=" -L${STAGING_LIBDIR}"
25 EXTRA_OEMAKE = "'SUBDIRS=intl mmalloc libiberty opcodes bfd sim gdb etc utils'"
26
27 EXTRA_OECONF = "--disable-gdbtk --disable-tui --disable-x \
28                 --with-curses --disable-multilib --with-readline --disable-sim \
29                 --program-prefix=''"
30
31 S = "${WORKDIR}/gdb-${PV}"
32 B = "${WORKDIR}/build-${TARGET_SYS}"
33
34 do_configure () {
35 # override this function to avoid the autoconf/automake/aclocal/autoheader
36 # calls for now
37         (cd ${S} && gnu-configize) || die "failure in running gnu-configize"
38         CPPFLAGS="" oe_runconf
39 }
40
41 do_install () {
42         make -C bfd/doc chew LDFLAGS= CFLAGS=-O2
43         oe_runmake install \
44             'prefix=${D}' 'exec_prefix=${D}' 'bindir=${D}${base_bindir}' \
45             'sbindir=${D}${base_sbindir}' 'infodir=${D}/share/info' 'libdir=${D}${base_libdir}' \
46             'mandir=${D}/share/man' 'includedir=${D}/include'
47         install -d ${D}${bindir}
48         install -m 0755 gdb/gdbserver/gdbserver ${D}${bindir}
49 }