]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/giac/giac_0.5.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / giac / giac_0.5.0.bb
1 SECTION = "console/utils"
2 DESCRIPTION = "A free computer algebra system"
3 HOMEPAGE = "http://www-fourier.ujf-grenoble.fr/~parisse/giac.html"
4 PRIORITY = "optional"
5 LICENSE = "GPL"
6 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
7 DEPENDS = "fltk gmp mpfr gsl"
8 #          ntl pari"
9
10 SRC_URI = "ftp://ftp-fourier.ujf-grenoble.fr/xcas/giac-${PV}.tar.gz"
11
12 inherit autotools
13
14 PACKAGES += " lib${PN}"
15 FILES_${PN} = "${bindir} \
16                ${datadir}/${PN}"
17 FILES_lib${PN} = "${libdir}"
18
19 # breaks the build...
20 #EXTRA_OECONF = "--enable-debug=no"
21
22 # skip autoreconf for now (fails due to improper local macros)
23 do_configure() {
24         oe_runconf
25 }
26
27 do_install () {
28         oe_runmake prefix="${D}${prefix}" \
29                 bindir="${D}${bindir}" \
30                 libdir="${D}${libdir}" \
31                 includedir="${D}${includedir}" \
32                 install
33
34         # put the docs where they belong
35         # might need further investigation in case giac needs
36         # them in the original place
37         install -d ${D}${docdir}
38         mv ${D}${datadir}/${PN}/doc ${D}${docdir}/${PN}
39 }