]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gnokii/gnokii_0.6.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gnokii / gnokii_0.6.4.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Cellphone tools and driver software"
3 SRC_URI = "http://www.gnokii.org/download/gnokii/0.6.x/gnokii-${PV}.tar.bz2 \
4         file://configure.patch;patch=1"
5 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
6
7 DEPENDS = "xpm"
8
9 inherit autotools pkgconfig
10
11 PACKAGES += "libgnokii libgnokii-dev"
12
13 FILES_${PN} = "${bindir} ${sbindir}"
14 FILES_libgnokii-dev = "${includedir} ${libdir}/lib*.so ${libdir}/*.la \
15                 ${libdir}/*.a ${libdir}/*.o ${libdir}/pkgconfig \
16                 /lib/*.a /lib/*.o ${datadir}/aclocal"
17 FILES_${PN}-dev = ""
18 FILES_libgnokii = "${libdir}/libgnokii.so.*"
19
20 do_stage() {
21         autotools_stage_includes
22
23         oe_libinstall -C common -so libgnokii ${STAGING_LIBDIR}
24 }
25