]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gnome-themes/gnome-themes_2.6.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gnome-themes / gnome-themes_2.6.2.bb
1 SECTION = "x11/base"
2 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
3 LICENSE = "LGPL"
4 DESCRIPTION = "GNOME themes"
5
6 DEPENDS = "gtk-engines intltool-native"
7
8 PACKAGES += " gtk-engine-crux gtk-engine-hc gtk-engine-lighthouseblue gtk-engine-mist gtk-engine-thinice"
9 FILES_gtk-engine-crux = "${libdir}/gtk-2.0/*/engines/libcrux-engine.so"
10 FILES_gtk-engine-hc = "${libdir}/gtk-2.0/*/engines/libhcengine.so"
11 FILES_gtk-engine-lighthouseblue = "${libdir}/gtk-2.0/*/engines/liblighthouseblue.so"
12 FILES_gtk-engine-mist = "${libdir}/gtk-2.0/*/engines/libmist.so"
13 FILES_gtk-engine-thinice = "${libdir}/gtk-2.0/*/engines/libthinice.so"
14
15 PACKAGES += " gnome-theme-crux gnome-theme-grand-canyon gnome-theme-highcontrast gnome-theme-highcontrastinverse gnome-theme-highcontrastlargeprint gnome-theme-highcontrastlargeprintinverse gnome-theme-largeprint gnome-theme-lighthouseblue gnome-theme-mist gnome-theme-traditional"
16 FILES_gnome-theme-crux = "${datadir}/themes/Crux"
17 FILES_gnome-theme-grand-canyon = "${datadir}/themes/Grand-Canyon"
18 FILES_gnome-theme-highcontrast = "${datadir}/themes/HighContrast"
19 FILES_gnome-theme-highcontrastinverse = "${datadir}/themes/HighContrastInverse"
20 FILES_gnome-theme-highcontrastlargeprint = "${datadir}/themes/HighContrastLargePrint"
21 FILES_gnome-theme-highcontrastlargeprintinverse = "${datadir}/themes/HighContrastLargePrintInverse"
22 FILES_gnome-theme-largeprint = "${datadir}/themes/LargePrint"
23 FILES_gnome-theme-lighthouseblue = "${datadir}/themes/LighthouseBlue"
24 FILES_gnome-theme-mist = "${datadir}/themes/Mist"
25 FILES_gnome-theme-traditional = "${datadir}/themes/Traditional"
26
27 SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
28
29 # gcc-3.4 blows up in gtktext with -frename-registers on arm-linux
30 CFLAGS := "${@'${CFLAGS}'.replace('-frename-registers', '')}"
31
32 inherit autotools