]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gnumeric/gnumeric_1.3.1.cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gnumeric / gnumeric_1.3.1.cvs.bb
1 LICENSE = "GPL"
2 SECTION = "x11/utils"
3 #CVSDATE="20040719"
4 CVSTAG="GNUMERIC_1_3_1"
5
6 DEFAULT_PREFERENCE = "-1"
7
8 S = "${WORKDIR}/gnumeric"
9
10
11 PR = "r1"
12 SRC_URI = "cvs://anonymous@anoncvs.gnome.org/cvs/gnome;module=gnumeric;tag=${CVSTAG} \
13            file://gnumeric-doc.make.patch;patch=1 \
14            file://Makefile.am.patch;patch=1"
15            
16 DEPENDS = "libgsf1 gtk+ libxml2 libglade libart-lgpl intltool-native libgnomecanvas libgnomeprint libgnomeprintui" 
17
18
19 EXTRA_OECONF = "--without-gnome"
20
21 do_configure_prepend() {
22         touch xmldocs.make
23         intltoolize --automake --debug
24 #       # aclocal seems to insist on looking in here.  Make sure it exists.
25 #       mkdir -p ${S}/m4
26 #       # work around automake lossage with AC_CONFIG_AUX_DIR
27 #       ( cd libmutt; libtoolize --force ; cp ../ltmain.sh . )
28 }
29
30 inherit autotools