]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gnupg/gnupg_1.4.5-1.bb
gnupg: add 1.4.5-1 from Debian.
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gnupg / gnupg_1.4.5-1.bb
1 DESCRIPTION = "GNU privacy guard - a free PGP replacement"
2 HOMEPAGE = "http://www.gnupg.org/"
3 SECTION = "console/utils"
4 LICENSE = "GPLv2"
5
6 DEPENDS = "zlib bzip2 readline"
7
8 inherit autotools gettext debian-vampyre
9
10 SRC_URI += "file://15_free_caps.dpatch;patch=1 \
11         file://16_min_privileges.dpatch;patch=1 \
12         file://24_gpgv_manpage_cleanup.dpatch;patch=1;pnum=0 \
13         file://25_de.po_fixes.dpatch;patch=1 \
14         file://tar-ustar-1.4.3.m4"
15
16 EXTRA_OECONF = "--disable-ldap \
17                 --with-zlib=${STAGING_LIBDIR}/.. \
18                 --with-bzip2=${STAGING_LIBDIR}/.. \
19                 --disable-selinux-support"
20 EXTRA_OECONF += "--with-readline=${STAGING_LIBDIR}/.. \
21                  --without-libcurl \
22                  --without-libusb"
23
24 do_configure () {
25         cp ${WORKDIR}/tar-ustar-1.4.3.m4 ${S}/m4/tar-ustar.m4
26         autotools_do_configure
27 }
28
29 do_install () {
30         autotools_do_install
31         install -d ${D}${docdir}/${PN}
32         mv ${D}${datadir}/${PN}/* ${D}/${docdir}/${PN}/ || :
33         mv ${D}${prefix}/doc/* ${D}/${docdir}/${PN}/ || :
34 }
35