]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gnuplot/gnuplot_4.0.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gnuplot / gnuplot_4.0.0.bb
1 DESCRIPTION = "Gnuplot is a portable command-line driven interactive datafile \
2 (text or binary) and function plotting utility."
3 SECTION = "console/scientific"
4 LICENSE = "BSD-4"
5 PRIORITY = "optional"
6 MAINTAINER = "Philip Frampton"
7 DEPENDS = "x11 libpng gd readline"
8 PR = "r4"
9
10 SRC_URI = "ftp://ftp.gnuplot.info/pub/gnuplot/gnuplot-${PV}.tar.gz \
11            file://subdirs.patch;patch=1 \
12            file://debian-separate-x11-package.patch;patch=1 \
13            http://www.mneuroth.de/privat/zaurus/qtplot-0.2.tar.gz \
14            file://matrix.patch;patch=1 \
15            file://term.patch;patch=1 \
16            file://gnuplot.desktop \
17            file://gnuplot.png"
18
19 inherit autotools 
20
21 PACKAGES =+ "${PN}-x11"
22 DESCRIPTION_${PN}-x11 = "X11 display terminal for Gnuplot."
23 SECTION_${PN}-x11 = "x11/scientific"
24 FILES_${PN}-x11 = "${libexecdir} ${datadir}/applications ${datadir}/pixmaps"
25 RDEPENDS_${PN}-x11 = "${PN}"
26
27 acpaths = ""
28 EXTRA_OECONF = "--with-readline=${STAGING_LIBDIR}/.. \
29                 --without-plot \
30                 --with-png=${STAGING_LIBDIR}/.. \
31                 --with-gd=${STAGING_LIBDIR}/.. \
32                 --without-lisp-files \
33                 --without-tutorial"
34
35 do_compile_prepend() {
36         install -m 0644 ${WORKDIR}/qtplot-0.2/qtopia.trm ${S}/term/
37 }
38
39 do_install_append() {
40         install -d ${D}${datadir}/applications/
41         install -m 0644 ${WORKDIR}/gnuplot.desktop ${D}${datadir}/applications/
42         install -d ${D}${datadir}/pixmaps/
43         install -m 0644 ${WORKDIR}/gnuplot.png ${D}${datadir}/pixmaps/
44 }