]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gpe-bootsplash/gpe-bootsplash_1.14.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gpe-bootsplash / gpe-bootsplash_1.14.bb
1 inherit gpe
2
3 DEPENDS = "gtk+ libsvg-cairo"
4 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5 SECTION = "gpe"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8 PR = "r6"
9
10 SRC_URI += "file://splash-p.svg file://splash-l.svg \
11             file://c7x0-rotation.patch;patch=1 \
12             file://cxx0-rotation.patch;patch=1 \
13                         file://cairofix.patch;patch=1"
14 SRC_URI_append_mnci = " file://mnci.patch;patch=1"
15
16 FILES_${PN} += "${datadir}/gpe"
17
18 do_install_append() {
19         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
20         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
21         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S03bootsplash
22 }
23