]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gpe-bootsplash/gpe-bootsplash_1.15.bb
941ac64ff0fc86b62ecd99c638b5e332ead81c50
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gpe-bootsplash / gpe-bootsplash_1.15.bb
1 inherit gpe
2
3 DEPENDS = "glib-2.0 libsvg-cairo"
4 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
5 SECTION = "gpe"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8 PR = "r2"
9
10 SRC_URI += "file://svg-cairo-only.patch;patch=1 \
11             file://splash-p.svg \
12             file://splash-l.svg"
13
14 FILES_${PN} += "${datadir}/gpe"
15
16 do_install_append() {
17         install -m 0644 ${WORKDIR}/splash-p.svg ${D}${datadir}/gpe/splash-p.svg
18         install -m 0644 ${WORKDIR}/splash-l.svg ${D}${datadir}/gpe/splash-l.svg
19         mv ${D}${sysconfdir}/rcS.d/S00bootsplash ${D}${sysconfdir}/rcS.d/S07bootsplash
20 }
21