]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gpe-mini-browser/gpe-mini-browser_cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gpe-mini-browser / gpe-mini-browser_cvs.bb
1 PR =                    "r2"
2 PV =                    "0.17+cvs-${CVSDATE}"
3
4 SRC_URI =               "${HANDHELDS_CVS};module=gpe/base/gpe-mini-browser"
5 DESCRIPTION =   "A lightweight webbrowser for the GPE platform"
6 LICENSE =               "GPL"
7 DEPENDS =               "sqlite gettext gtk+ glib-2.0 osb-nrcit libgpewidget"
8 RRECOMMENDS =   "gdk-pixbuf-loader-gif gdk-pixbuf-loader-png gdk-pixbuf-loader-jpeg"
9  
10 DEFAULT_PREFERENCE = "-1"
11
12 S = "${WORKDIR}/gpe-mini-browser"
13
14 inherit autotools
15
16 do_install() {
17         #       install -d ${D}${docdir}/gpe
18         #       install -m 0644 ${S}/gpe-mini-browser.html  ${D}${docdir}/gpe/
19                 install -d ${D}/usr/share/applications
20                 install -m 0644 ${S}/gpe-mini-browser.desktop ${D}/usr/share/applications/gpe-mini-browser.desktop
21                 install -d ${D}/usr/share/pixmaps
22                 install -m 0644 ${S}/gpe-mini-browser.png ${D}/usr/share/pixmaps/gpe-mini-browser.png
23                 autotools_do_install
24 }
25
26 pkg_postinst_${PN}-doc () {
27         #!/bin/sh
28         if [ "x$D" != "x" ]; then
29         if [ -e /etc/gpe/gpe-help.conf ]; then
30                 echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
31         else
32                  echo [Help] >> /etc/gpe/gpe-help.conf
33                  echo gpe-mini-browser= /usr/share/doc/gpe/gpe-mini-browser.html >> /etc/gpe/gpe-help.conf
34         fi
35         if [ -x /usr/bin/gpe-helpindex ]; then
36                 echo generating help-index
37                 gpe-helpindex
38         else
39                 echo not generating index for gpe-mini-browser
40         fi
41         fi
42 }
43
44 pkg_postrm_${PN}-doc () {
45         #!/bin/sh
46         if [ -e /etc/gpe/gpe-help.conf ]; then
47                 sed '/^\<gpe-mini-browser\>/d' /etc/gpe/gpe-help.conf > /tmp/gpe-help.conf
48                 mv /tmp/gpe-help.conf /etc/gpe/gpe-help.conf
49         fi
50         if [ -x /usr/bin/gpe-helpindex ]; then
51                 echo generating help-index
52                 gpe-helpindex
53         else
54                 echo not generating index for gpe-mini-browser
55         fi
56 }