]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gpm/gpm_1.20.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gpm / gpm_1.20.1.bb
1 SECTION = "console/utils"
2 LICENSE = "GPL"
3 DEPENDS = "ncurses"
4 DESCRIPTION = "GPM (General Purpose Mouse) is a mouse server \
5 for the console and xterm, with sample clients included \
6 (emacs, etc)."
7
8 SRC_URI = "ftp://arcana.linux.it/pub/gpm/gpm-${PV}.tar.bz2 \
9            file://configure.patch;patch=1 \
10            file://no-docs.patch;patch=1"
11
12 inherit autotools
13
14 export LIBS = "-lm"
15 do_configure_prepend () {
16         cp aclocal.m4 acinclude.m4
17 }
18
19 do_stage () {
20         install -m 0644 src/headers/gpm.h ${STAGING_INCDIR}/
21         oe_libinstall -so -a -C src/lib libgpm ${STAGING_LIBDIR}
22 }
23
24 do_install () {
25         oe_runmake 'ROOT=${D}' install
26 }