]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gpsd/gpsd_2.6.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gpsd / gpsd_2.6.bb
1 DESCRIPTION = "A TCP/IP Daemon simplifying the communication with GPS devices"
2 SECTION = "network"
3 PRIORITY = "optional"
4 MAINTAINER = "Robert Anderson <rea@sr.unh.edu>"
5 LICENSE = "GPL"
6 PR = "r1"
7
8 SRC_URI = "http://ftp.berlios.de/gpsd/gpsd-${PV}.tar.gz"
9
10 inherit autotools update-rc.d
11
12 INITSCRIPT_NAME = "gpsd"
13 INITSCRIPT_PARAMS = "defaults 35"
14
15 LDFLAGS = "-lm"
16
17 do_configure() {
18         oe_runconf 
19 }
20
21 do_compile() {
22         oe_runmake gpsd gpsd.1 libgps.3 libgpsd.3 gps.h gpsd.h
23 }
24
25 do_stage () {
26         oe_libinstall -so -C ${S}/.libs libgps ${STAGING_LIBDIR}
27         install -m 0655 ${S}/libgps.la ${STAGING_LIBDIR}
28         install -m 0655 ${S}/gps.h ${STAGING_INCDIR}
29         install -m 0655 ${S}/gpsd.h ${STAGING_INCDIR}
30 }
31
32 do_install () {
33         install -d ${D}${sbindir}
34         install -d ${D}${mandir}/man1
35         install -d ${D}${mandir}/man3
36         install -d ${D}${incdir}
37         install -d ${D}${libdir}
38         install -d ${D}${sysconfdir}/init.d
39
40         install -m 0755 ${S}/.libs/gpsd ${D}${sbindir}
41         oe_libinstall -so -C ${S}/.libs libgps ${D}${libdir}
42         install -m 755 gpsd.1 ${D}${mandir}/man1/gpsd.1
43         install -m 0755 ${S}/libgps.la ${D}${libdir}libgps.la
44         install -m 0755 ${S}/gps.h ${S}/gpsd.h ${D}${incdir}
45         install -m 755 libgps.3 libgpsd.3 ${D}${mandir}/man3/
46         install -m 755 gpsd.init ${D}${sysconfdir}/init.d/gpsd
47 }
48
49 PACKAGES =+ "gpsd-devdoc "
50 FILES_${PN}-devdoc = "${mandir}/man3 "