]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/grub/grub_0.93.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / grub / grub_0.93.bb
1 SECTION = "base"
2 DESCRIPTION = "grand unified bootloader"
3
4 SRC_URI = "ftp://alpha.gnu.org/gnu/grub/grub-${PV}.tar.gz; \
5            file://autohell.patch;patch=1 \
6            file://memcpy.patch;patch=1 \
7            file://reiserfs.patch;patch=1"
8
9 S = "${WORKDIR}/grub-${PV}"
10
11 inherit autotools
12
13 python __anonymous () {
14         import re
15         host = bb.data.getVar('HOST_SYS', d, 1)
16         if not re.match('i.86.*-linux', host):
17                 raise bb.parse.SkipPackage("incompatible with host %s" % host)
18 }