]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gs/gs_8.16.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gs / gs_8.16.bb
1 DESCRIPTION = "An interpreter of the Postscript language"
2 LICENSE = "GPL"
3 SECTION = "console/utils"
4 HOMEPAGE = "http://www.gnu.org/software/ghostscript/ghostscript.html"
5 DEPENDS = "jpeg zlib"
6 PR = "r0"
7
8 SRC_URI = "${GNU_MIRROR}/ghostscript/gnu-ghostscript-${PV}.tar.gz"
9 S = "${WORKDIR}/gnu-ghostscript-${PV}"
10
11 inherit autotools flow-lossage
12
13 EXTRA_OECONF = "--without-x"
14
15 do_configure() {
16         gnu-configize
17         oe_runconf
18 }
19
20 do_compile() {
21         oe_runmake CCAUX="${BUILD_CC}"
22 }
23
24 do_install() {
25         oe_runmake bindir='${D}${bindir}' datadir='${D}${datadir}' libdir='${D}${libdir}' install
26 }
27
28 FILES_${PN} += "${datadir}/ghostscript"