]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gstreamer/gst-plugins_0.8.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gstreamer / gst-plugins_0.8.4.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Plugins for GStreamer"
3 SECTION = "x11/libs"
4 PRIORITY = "optional"
5 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
6 PR = "r2"
7
8 DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
9
10 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
11            file://ivorbis.patch;patch=1 \
12            file://try-esdsink.patch;patch=1 \
13            file://lame-autoconf.patch;patch=1"
14
15 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
16                 --disable-artsc --disable-libfame --disable-sdl --disable-shout2 \
17                 --disable-gnome_vfs "
18
19 inherit autotools pkgconfig gconf
20
21 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
22
23 LIBV = "0.8"
24
25 plugin_postinst() {
26         if [ x"$D" = "x" ]; then
27                 gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
28         fi
29 }
30
31 python populate_packages_prepend () {
32         gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
33         postinst = bb.data.getVar('plugin_postinst', d, 1)
34
35         do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
36         do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
37 }
38
39 do_stage() {
40         autotools_stage_includes
41         while read a b; do
42                 oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
43         done <<EOF
44 . interfaces-0.8
45 audio audio
46 audio audiofilter
47 gconf gconf-0.8
48 idct idct
49 media-info media-info-0.8
50 play play-0.8
51 resample resample
52 riff riff
53 video video
54 xwindowlistener xwindowlistener
55 EOF
56 }