]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gstreamer/gst-plugins_0.8.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gstreamer / gst-plugins_0.8.7.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Plugins for GStreamer"
3 SECTION = "x11/libs"
4 PRIORITY = "optional"
5 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
6 PR = "r3"
7
8 DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
9
10 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
11            file://gst-plugins-0.8.7-httpsrc1.patch;patch=1 \
12            file://lame-autoconf.patch;patch=1 \
13            file://try-esdsink.patch;patch=1"
14
15 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
16                 --disable-artsc --disable-jack  --disable-libfame --disable-sdl --disable-shout2 \
17                 --disable-gnome_vfs --disable-gconf --disable-libcaca  --disable-directfb \
18                 --disable-cairo"
19
20 inherit autotools pkgconfig gconf
21
22 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
23
24 LIBV = "0.8"
25
26 plugin_postinst() {
27         if [ x"$D" = "x" ]; then
28                 gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
29         fi
30 }
31
32 python populate_packages_prepend () {
33         gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
34         postinst = bb.data.getVar('plugin_postinst', d, 1)
35
36         do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
37         do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
38 }
39
40 do_stage() {
41         autotools_stage_includes
42         while read a b; do
43                 oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
44         done <<EOF
45 . interfaces-0.8
46 audio audio
47 audio audiofilter
48 gconf gconf-0.8
49 idct idct
50 media-info media-info-0.8
51 play play-0.8
52 resample resample
53 riff riff
54 video video
55 xwindowlistener xwindowlistener
56 EOF
57 }