]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gstreamer/gst-plugins_0.8.8.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gstreamer / gst-plugins_0.8.8.bb
1 LICENSE = "GPL"
2 DESCRIPTION = "Plugins for GStreamer"
3 SECTION = "x11/libs"
4 PRIORITY = "optional"
5 MAINTAINER = "Phil Blundell <pb@handhelds.org>"
6 PR = "r0"
7
8 DEFAULT_PREFERENCE = "-1"
9
10 DEPENDS = "gstreamer libmikmod libmad libogg tremor libvorbis libid3tag gpe-soundserver gconf"
11
12 SRC_URI = "http://gstreamer.freedesktop.org/src/gst-plugins/gst-plugins-${PV}.tar.bz2 \
13            file://gst-plugins-0.8.7-httpsrc1.patch;patch=1 \
14            file://lame-autoconf.patch;patch=1 \
15            file://gst-plugins-0.8.8-try-esdsink.patch;patch=1"
16
17 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-aalib --disable-arts \
18                 --disable-artsc --disable-jack  --disable-libfame --disable-sdl --disable-shout2 \
19                 --disable-gnome_vfs --disable-gconf --disable-libcaca  --disable-directfb \
20                 --disable-cairo"
21
22 inherit autotools pkgconfig gconf
23
24 acpaths = "-I ${S}/common/m4 -I ${S}/m4"
25
26 LIBV = "0.8"
27
28 plugin_postinst() {
29         if [ x"$D" = "x" ]; then
30                 gst-register --gst-registry=/var/cache/gstreamer-0.8/registry.xml
31         fi
32 }
33
34 python populate_packages_prepend () {
35         gst_libdir = bb.data.expand('${libdir}/gstreamer-${LIBV}', d)
36         postinst = bb.data.getVar('plugin_postinst', d, 1)
37
38         do_split_packages(d, gst_libdir, '^libgst(.*)\.so$', 'gst-plugin-%s', 'GStreamer plugin for %s', postinst=postinst)
39         do_split_packages(d, gst_libdir, '^libgst(.*)\.l?a$', 'gst-plugin-%s-dev', 'GStreamer plugin for %s (development files)')
40 }
41
42 do_stage() {
43         autotools_stage_includes
44         while read a b; do
45                 oe_libinstall -C gst-libs/gst/$a -so libgst$b ${STAGING_LIBDIR}
46         done <<EOF
47 . interfaces-0.8
48 audio audio
49 audio audiofilter
50 gconf gconf-0.8
51 idct idct
52 media-info media-info-0.8
53 play play-0.8
54 resample resample
55 riff riff
56 video video
57 xwindowlistener xwindowlistener
58 EOF
59 }