]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gstreamer/gstreamer_0.8.9.bb
02e93b78ec703f528db5ffecc0dab0538ccf83e8
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gstreamer / gstreamer_0.8.9.bb
1 LICENSE = "LGPL"
2 PR = "r4"
3
4 DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
5 It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
6 DEPENDS = "glib-2.0 gettext-native popt"
7 SECTION = "base"
8 PRIORITY = "optional"
9
10 FILES_${PN} += " ${libdir}/gstreamer-0.8/*.so"
11 FILES_${PN}-dev += " ${libdir}/gstreamer-0.8/*.la ${libdir}/gstreamer-0.8/*.a"
12
13 SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2 \
14         file://libm.patch;patch=1 \
15         file://no-libxml2.patch;patch=1 \
16         file://filesrc-uri.patch;patch=1 \
17         file://gstreamer.xsession"
18
19 EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --disable-loadsave"
20
21 inherit autotools pkgconfig
22
23 do_stage() {
24         oe_runmake install prefix=${STAGING_DIR} \
25                bindir=${STAGING_BINDIR} \
26                includedir=${STAGING_INCDIR} \
27                libdir=${STAGING_LIBDIR} \
28                datadir=${STAGING_DATADIR} \
29                mandir=${STAGING_DIR}/share/man
30 }
31
32 do_install_append() {
33         install -d ${D}${sysconfdir}/X11/Xsession.d
34         install ${WORKDIR}/gstreamer.xsession ${D}${sysconfdir}/X11/Xsession.d/90gst-register
35 }
36