]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gtk+/gtk+_2.4.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gtk+ / gtk+_2.4.4.bb
1 LICENSE = "LGPL"
2 DESCRIPTION = "GTK+ is a multi-platform toolkit for creating graphical user interfaces. Offering a complete \
3 set of widgets, GTK+ is suitable for projects ranging from small one-off projects to complete application suites."
4 HOMEPAGE = "http://www.gtk.org"
5 SECTION = "libs"
6 PRIORITY = "optional"
7 MAINTAINER = "Philip Blundell <pb@handhelds.org>"
8 DEPENDS = "glib-2.0 pango atk jpeg libpng xext libxcursor"
9 PR = "r7"
10
11 SRC_URI = "ftp://ftp.gtk.org/pub/gtk/v2.4/gtk+-${PV}.tar.bz2 \
12            file://no-demos.patch;patch=1 \
13            file://no-xwc.patch;patch=1;pnum=0 \
14            file://automake-lossage.patch;patch=1 \
15            file://single-click.patch;patch=1 \
16            file://gtk+-handhelds.patch;patch=1 \
17            file://hardcoded_libtool.patch;patch=1 \
18            file://spinbutton.patch;patch=1 \
19            file://disable-tooltips.patch;patch=1 \
20            file://gtklabel-resize-patch;patch=1 \
21            file://gtk-doc.m4 \
22            file://small-gtkfilesel.patch;patch=1"
23
24 inherit autotools pkgconfig flow-lossage
25
26 do_configure_prepend() {
27         install -d m4
28         install ${WORKDIR}/gtk-doc.m4 m4/
29 }
30
31 FILES_${PN} += "${datadir}/themes"
32 FILES_${PN}-dev += "${datadir}/gtk-2.0/include ${libdir}/gtk-2.0/include"
33
34 EXTRA_OECONF = "--without-libtiff --enable-debug=no --disable-xkb --disable-glibtest"
35 # --disable-cruft
36
37 LIBV = "2.4.0"
38
39 gtk_include = "gtk.h gtkaccelgroup.h gtkaccellabel.h gtkaccelmap.h gtkaccessible.h gtkadjustment.h gtkalignment.h gtkarrow.h gtkaspectframe.h gtkbbox.h gtkbin.h gtkbindings.h gtkbox.h gtkbutton.h gtkcalendar.h gtkcelleditable.h gtkcellrenderer.h gtkcellrendererpixbuf.h gtkcellrenderertext.h gtkcellrenderertoggle.h gtkcheckbutton.h gtkcheckmenuitem.h gtkclipboard.h gtkclist.h gtkcolorsel.h gtkcolorseldialog.h gtkcombo.h gtkcontainer.h gtkctree.h gtkcurve.h gtkdebug.h gtkdialog.h gtkdnd.h gtkdrawingarea.h gtkeditable.h gtkentry.h gtkenums.h gtkeventbox.h gtkfilesel.h gtkfixed.h gtkfontsel.h gtkframe.h gtkgamma.h gtkgc.h gtkhandlebox.h gtkhbbox.h gtkhbox.h gtkhpaned.h gtkhruler.h gtkhscale.h gtkhscrollbar.h gtkhseparator.h gtkiconfactory.h gtkimage.h gtkimagemenuitem.h gtkimcontext.h gtkimcontextsimple.h gtkimmodule.h gtkimmulticontext.h gtkinputdialog.h gtkinvisible.h gtkitem.h gtkitemfactory.h gtklabel.h gtklayout.h gtklist.h gtklistitem.h gtkliststore.h gtkmain.h gtkmarshal.h gtkmenu.h gtkmenubar.h gtkmenuitem.h gtkmenushell.h gtkmessagedialog.h gtkmisc.h gtknotebook.h gtkobject.h gtkoldeditable.h gtkoptionmenu.h gtkpaned.h gtkpixmap.h gtkplug.h gtkpreview.h gtkprivate.h gtkprogress.h gtkprogressbar.h gtkradiobutton.h gtkradiomenuitem.h gtkrange.h gtkrc.h gtkruler.h gtkscale.h gtkscrollbar.h gtkscrolledwindow.h gtkselection.h gtkseparator.h gtkseparatormenuitem.h gtksettings.h gtksignal.h gtksizegroup.h gtksocket.h gtkspinbutton.h gtkstatusbar.h gtkstock.h gtkstyle.h gtktable.h gtktearoffmenuitem.h gtktext.h gtktextbuffer.h gtktextchild.h gtktextdisplay.h gtktextiter.h gtktextlayout.h gtktextmark.h gtktexttag.h gtktexttagtable.h gtktextview.h gtktipsquery.h gtktogglebutton.h gtktoolbar.h gtktooltips.h gtktree.h gtktreednd.h gtktreeitem.h gtktreemodel.h gtktreemodelsort.h gtktreeselection.h gtktreesortable.h gtktreestore.h gtktreeview.h gtktreeviewcolumn.h gtktypebuiltins.h gtktypeutils.h gtkvbbox.h gtkvbox.h gtkversion.h gtkviewport.h gtkvpaned.h gtkvruler.h gtkvscale.h gtkvscrollbar.h gtkvseparator.h gtkwidget.h gtkwindow.h gtkentrycompletion.h gtkcomboboxentry.h gtkcolorbutton.h gtkcombobox.h gtkcelllayout.h gtkactiongroup.h gtkaction.h gtkexpander.h gtkfilechooserdialog.h gtkfilechooserwidget.h gtkfontbutton.h gtkicontheme.h gtkradioaction.h gtkradiotoolbutton.h gtkseparatortoolitem.h gtktoggleaction.h gtktoggletoolbutton.h gtktoolitem.h gtkuimanager.h gtktreemodelfilter.h gtktoolbutton.h gtkfilechooser.h gtkfilefilter.h gtkfilesystem.h"
40 gdk_include = "gdk.h gdkcolor.h gdkcursor.h gdkdisplay.h gdkdisplaymanager.h gdkdnd.h gdkdrawable.h gdkenumtypes.h gdkevents.h gdkfont.h gdkgc.h gdki18n.h gdkimage.h gdkinput.h gdkkeys.h gdkkeysyms.h gdkpango.h gdkpixbuf.h gdkpixmap.h gdkprivate.h gdkproperty.h gdkregion.h gdkrgb.h gdkscreen.h gdkselection.h gdktypes.h gdkvisual.h gdkwindow.h x11/gdkx.h gdkspawn.h"
41 gdk_pixbuf_include = "gdk-pixbuf-animation.h gdk-pixbuf-enum-types.h gdk-pixbuf-features.h gdk-pixbuf-io.h gdk-pixbuf-loader.h gdk-pixbuf-marshal.h gdk-pixbuf.h gdk-pixdata.h"
42
43 do_stage () {
44         oe_libinstall -so -C gtk libgtk-x11-2.0 ${STAGING_LIBDIR}
45         oe_libinstall -so -C gdk libgdk-x11-2.0 ${STAGING_LIBDIR}
46         oe_libinstall -so -C contrib/gdk-pixbuf-xlib libgdk_pixbuf_xlib-2.0 ${STAGING_LIBDIR}
47         oe_libinstall -so -C gdk-pixbuf libgdk_pixbuf-2.0 ${STAGING_LIBDIR}
48
49         mkdir -p ${STAGING_INCDIR}/gtk-2.0/gtk
50         for i in ${gtk_include}; do
51                 install -m 0644 gtk/$i ${STAGING_INCDIR}/gtk-2.0/gtk/$i
52         done
53
54         mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk
55         for i in ${gdk_include}; do
56                 install -m 0644 gdk/$i ${STAGING_INCDIR}/gtk-2.0/gdk/`basename $i`
57         done
58
59         mkdir -p ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf
60         for i in ${gdk_pixbuf_include}; do
61                 install -m 0644 gdk-pixbuf/$i ${STAGING_INCDIR}/gtk-2.0/gdk-pixbuf/$i
62         done
63
64         mkdir -p ${STAGING_LIBDIR}/gtk-2.0/include
65         install -m 0644 gdk/gdkconfig.h ${STAGING_LIBDIR}/gtk-2.0/include/gdkconfig.h
66
67         install -m 0644 m4macros/gtk-2.0.m4 ${STAGING_DATADIR}/aclocal/
68 }
69
70 do_install_append () {
71         install -d ${D}${sysconfdir}/gtk-2.0
72 }
73
74 python populate_packages_prepend () {
75         import os.path
76
77         gtk_libdir = bb.data.expand('${libdir}/gtk-2.0/${LIBV}', d)
78         loaders_root = os.path.join(gtk_libdir, 'loaders')
79         immodules_root = os.path.join(gtk_libdir, 'immodules')
80
81         do_split_packages(d, loaders_root, '^libpixbufloader-(.*)\.so$', 'gdk-pixbuf-loader-%s', 'GDK pixbuf loader for %s', 'gdk-pixbuf-query-loaders > /etc/gtk-2.0/gdk-pixbuf.loaders')
82         do_split_packages(d, immodules_root, '^im-(.*)\.so$', 'gtk-immodule-%s', 'GTK input module for %s', 'gtk-query-immodules > /etc/gtk-2.0/gtk.immodules')
83
84         if (bb.data.getVar('DEBIAN_NAMES', d, 1)):
85                 bb.data.setVar('PKG_${PN}', 'libgtk-2.0', d)
86 }