]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gtk-webcore/osb-nrcit_0.5.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gtk-webcore / osb-nrcit_0.5.0.bb
1 DESCRIPTION = "Gtk+ WebCore - NRCit embeddable browser component"
2 LICENSE = "nokia"
3 HOMEPAGE = "http://gtk-webcore.sourceforge.net/"
4 PRIORITY = "optional"
5 MAINTAINER = "Rene Wagner <rw@handhelds.org>"
6 DEPENDS = "curl osb-nrcore"
7 SECTION = "gpe"
8 PR = "r2"
9
10 SRC_URI = "${SOURCEFORGE_MIRROR}/gtk-webcore/osb-nrcit-${PV}.tar.gz"
11
12 inherit autotools pkgconfig
13
14 do_configure () {
15         autotools_do_configure
16         cd ${S}
17
18         # prevent libtool from linking libs against libstdc++, libgcc, ...
19         cat ${TARGET_PREFIX}libtool | sed -e 's/postdeps=".*"/postdeps=""/' > ${TARGET_PREFIX}libtool.tmp
20         mv ${TARGET_PREFIX}libtool.tmp ${TARGET_PREFIX}libtool
21 }
22
23 do_stage () {
24         oe_libinstall -so -C src libnrcit ${STAGING_LIBDIR}
25
26         autotools_stage_includes
27         
28         install -d ${STAGING_INCDIR}/osb
29         install -m 0644 ${S}/src/gtk/gtk-khtml.h ${STAGING_INCDIR}/osb
30         install -m 0644 ${S}/src/osb.h ${STAGING_INCDIR}/osb
31 }