]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gxine/gxine_0.4.1enhanced.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gxine / gxine_0.4.1enhanced.bb
1 DESCRIPTION = "gxine is a front-end for libxine."
2 SECTION = "x11/multimedia"
3 LICENSE = "GPL"
4 MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
5 DEPENDS = "gtk+ libxine-x11"
6 PR = "r1"
7
8 # Long list of RDEPENDS required to playback mp3/ogg audio and mpeg/mpeg4 video
9 RDEPENDS = "libxine-plugin-vo-out-xshm \
10             libxine-plugin-vo-out-none \
11             libxine-plugin-ao-out-esd \
12             libxine-plugin-ao-out-none \
13             libxine-plugin-inp-file \
14             libxine-plugin-inp-http \
15             libxine-plugin-inp-net \
16             libxine-plugin-inp-mms \
17             libxine-plugin-decode-mad \
18             libxine-plugin-decode-vorbis \
19             libxine-plugin-decode-image \
20             libxine-plugin-decode-ff \
21             libxine-plugin-dmx-audio \
22             libxine-plugin-dmx-mpeg \
23             libxine-plugin-dmx-mpeg-block \
24             libxine-plugin-dmx-mpeg-elem \
25             libxine-plugin-dmx-mpeg-pes \
26             libxine-plugin-dmx-mpeg-ts \
27             libxine-plugin-dmx-ogg \
28             libxine-plugin-dmx-image \
29             libxine-plugin-dmx-avi"
30             
31 S = "${WORKDIR}/${PN}-0.4.1/"
32
33 SRC_URI = "${SOURCEFORGE_MIRROR}/xine/${PN}-0.4.1.tar.gz \
34            file://rhythmbox-volume-max.png \
35            file://rhythmbox-volume-medium.png \
36            file://rhythmbox-volume-min.png \
37            file://rhythmbox-volume-zero.png \
38            file://enhance.patch;patch=1"
39
40 EXTRA_OECONF = " --includedir=${STAGING_INCDIR} \
41                 --libdir=${STAGING_LIBDIR} \
42                 --disable-xinetest \
43                 --with-xine-prefix=${STAGING_DIR}/${HOST_SYS}"
44
45 LDFLAGS += "-lxine"
46
47 inherit autotools pkgconfig
48
49 do_configure_prepend () {
50         mv ${WORKDIR}/*.png ${S}/pixmaps/
51 }
52