]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/gzip/gzip_1.3.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / gzip / gzip_1.3.5.bb
1 LICENSE = "GPL"
2 SECTION = "console/utils"
3 PRIORITY = "required"
4 MAINTAINER = "Greg Gilbert <greg@treke.net>"
5 DESCRIPTION = "gzip (GNU zip) is a compression utility designed \
6 to be a replacement for 'compress'. The GNU Project uses it as \
7 the standard compression program for its system."
8 PR = "r1"
9
10 SRC_URI = "${DEBIAN_MIRROR}/main/g/gzip/gzip_${PV}.orig.tar.gz \
11            file://configure.patch;patch=1"
12
13 S = "${WORKDIR}/gzip-${PV}"
14
15 inherit autotools
16
17 do_install () {
18         autotools_do_install
19         # Rename and move files into /bin (FHS)
20         install -d ${D}${base_bindir}
21         mv ${D}${bindir}/gunzip ${D}${base_bindir}/gunzip.${PN}
22         mv ${D}${bindir}/gzip ${D}${base_bindir}/gzip.${PN}
23         mv ${D}${bindir}/zcat ${D}${base_bindir}/zcat.${PN}
24 }
25
26 pkg_postinst_${PN} () {
27         update-alternatives --install ${base_bindir}/gunzip gunzip gunzip.${PN} 100
28         update-alternatives --install ${base_bindir}/gzip gzip gzip.${PN} 100
29         update-alternatives --install ${base_bindir}/zcat zcat zcat.${PN} 100
30 }
31
32 pkg_prerm_${PN} () {
33         update-alternatives --remove gunzip gunzip.${PN}
34         update-alternatives --remove gzip gzip.${PN}
35         update-alternatives --remove zcat zcat.${PN}
36 }
37