]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hostap/hostap-daemon_0.3.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hostap / hostap-daemon_0.3.7.bb
1 DESCRIPTION = "User space daemon for extended IEEE 802.11 management"
2 HOMEPAGE = "http://hostap.epitest.fi"
3 SECTION = "kernel/userland"
4 PRIORITY = "optional"
5 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
6 LICENSE = "GPL"
7 RDEPENDS = "hostap-modules (${PV}) hostap-utils (${PV})"
8 DEPENDS_mtx-1_append = "madwifi-modules"
9
10 SRC_URI = "http://hostap.epitest.fi/releases/hostapd-${PV}.tar.gz \
11         file://makefile-cross.diff;patch=1;pnum=0 \
12         file://madwifi-bsd-fix.diff;patch=1;pnum=0 \
13         file://defconfig \
14         file://init"
15
16 S = "${WORKDIR}/hostapd-${PV}"
17
18 do_configure() {
19        install -m 0644 ${WORKDIR}/defconfig ${S}/.config
20 }
21
22 do_compile() {
23         CFLAGS='${CFLAGS}' CC='${CC}' make
24 }
25
26 do_install() {
27         install -d ${D}${sbindir} ${D}${sysconfdir}/init.d
28         make TARGET_PREFIX=${D}${sbindir} install
29         install -m 0644 hostapd.conf ${D}${sysconfdir}
30         install -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/hostapd
31 }