]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hostap/hostap-modules_0.3.7.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hostap / hostap-modules_0.3.7.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 PR = "r4"
7
8 SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
9            file://hostap_cs.conf \
10            file://Makefile.patch;patch=1 \
11            file://add_event.patch;patch=1 \
12            file://hostap-utsname.patch;patch=1"
13 SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
14         file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
15 SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
16
17 S = "${WORKDIR}/hostap-driver-${PV}"
18
19 inherit module
20
21 # Hack Alert :D
22 ARCH_mipsel = "mips"
23 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
24
25 NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
26
27 do_install() {
28         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
29                    ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
30                    ${D}${sysconfdir}/pcmcia
31         for i in ${NET_MODULES}
32         do
33                 install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
34         done
35         install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
36         install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
37         cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
38 }
39
40 PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
41 FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
42 FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
43 FILES_hostap-modules = "/lib/modules/"
44 RDEPENDS_hostap-modules-cs = "hostap-modules"
45 RDEPENDS_hostap-modules-pci = "hostap-modules"