]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hostap/hostap-modules_0.4.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hostap / hostap-modules_0.4.4.bb
1 DESCRIPTION = "A driver for wireless LAN cards based on Intersil's Prism2/2.5/3 chipset"
2 SECTION = "kernel/modules"
3 PRIORITY = "optional"
4 MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
5 LICENSE = "GPL"
6 PR = "r2"
7
8 SRC_URI = "http://hostap.epitest.fi/releases/hostap-driver-${PV}.tar.gz \
9            file://kernel_updates.patch;patch=1 \
10            file://hostap_cs.conf "
11
12 SRC_URI_append_mtx-1 = " file://mtx_compat.diff;patch=1;pnum=0 \
13         file://mtx_hostap_deferred_irq.diff;patch=1;pnum=0"
14 SRC_URI_append_h3900 = " file://ipaq_compat.patch;patch=1 "
15
16 S = "${WORKDIR}/hostap-driver-${PV}"
17
18 inherit module
19
20 # Hack Alert :D
21 ARCH_mipsel = "mips"
22 MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
23
24 NET_MODULES = "hostap hostap_pci hostap_crypt_ccmp hostap_crypt_tkip hostap_crypt_wep"
25
26 do_install() {
27         install -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/net \
28                    ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia \
29                    ${D}${sysconfdir}/pcmcia
30         for i in ${NET_MODULES}
31         do
32                 install -m 0644 driver/modules/$i${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/net/
33         done
34         install -m 0644 driver/modules/hostap_cs${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/pcmcia/
35         install -m 0644 driver/etc/hostap_cs.conf ${D}${sysconfdir}/pcmcia/hostap_cs.conf
36         cat ${WORKDIR}/hostap_cs.conf >>${D}${sysconfdir}/pcmcia/hostap_cs.conf
37 }
38
39 PACKAGES = "hostap-modules-cs hostap-modules-pci hostap-modules"
40 FILES_hostap-modules-cs = "/lib/modules/${KERNEL_VERSION}/pcmcia/ /${sysconfdir}/pcmcia/"
41 FILES_hostap-modules-pci = "/lib/modules/${KERNEL_VERSION}/net/hostap_pci${KERNEL_OBJECT_SUFFIX}"
42 FILES_hostap-modules = "/lib/modules/"
43 RDEPENDS_hostap-modules-cs = "hostap-modules"
44 RDEPENDS_hostap-modules-pci = "hostap-modules"