]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/hotplug-ng/hotplug-ng_001.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / hotplug-ng / hotplug-ng_001.bb
1 DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
2 package with very tiny, compiled executable programs, instead of the \
3 existing bash scripts."
4 LICENSE = "GPL"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 RPROVIDES = "hotplug"
7 RCONFLICTS = "hotplug"
8 RREPLACES = "hotplug"
9 PR = "r1"
10
11 SRC_URI = "http://www.kernel.org/pub/linux/utils/kernel/hotplug/hotplug-ng-${PV}.tar.gz \
12            file://flags.patch;patch=1"
13 S = "${WORKDIR}/hotplug-ng-${PV}"
14
15 LD = "${CC}"
16 export HOSTCC = "${BUILD_CC}"
17 # Stripping should be done when _packaging_, not building
18 EXTRA_OEMAKE += "'STRIP=/bin/true'"
19
20 export etcdir = "${sysconfdir}"
21 export sbindir = "${base_sbindir}"
22 export bindir = "${base_bindir}"
23
24 do_install () {
25         oe_runmake 'DESTDIR=${D}' install
26 }