]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/htb-init/htb-init_0.8.5.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / htb-init / htb-init_0.8.5.bb
1 DESCRIPTION = "HTB.init is a shell script that allows for easy setup of HTB-based traffic control on Linux."
2 HOMEPAGE = "http://sourceforge.net/projects/htbinit"
3 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
4 LICENSE = "GPL"
5 PR = "r1"
6
7 SRC_URI = "http://aleron.dl.sourceforge.net/sourceforge/htbinit/htb.init-v${PV} \
8         file://htb.init+ingress+predef+verbose.diff;patch=1;pnum=0 \
9         file://htb-basic-verbose.diff;patch=1;pnum=0"
10 RRECOMMENDS = "kernel-module-sch-ingress kernel-module-cls-route kernel-module-cls-u32 kernel-module-cls-fw kernel-module-sch-sfq kernel-module-sch-htb"
11 RDEPENDS = "iproute2 (>= 2.6.8-r1)"
12
13 S="${WORKDIR}"
14
15 do_install() {
16         install -d ${D}${sysconfdir}/init.d
17         install -d ${D}${sysconfdir}/htb
18         install -m 755 ${S}/htb.init-v${PV} ${D}${sysconfdir}/init.d/htb
19 }