]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ifupdown/ifupdown_0.6.4.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ifupdown / ifupdown_0.6.4.bb
1 BROKEN = "1" 
2 # Debian moved to 0.6.7
3
4 DESCRIPTION = "High level tools to configure network interfaces \
5 This package provides the tools ifup and ifdown which may be used to \
6 configure (or, respectively, deconfigure) network interfaces, based on \
7 the file /etc/network/interfaces."
8 LICENSE = "GPL"
9
10 SECTION = "base"
11
12 SRC_URI = "${DEBIAN_MIRROR}/main/i/ifupdown/ifupdown_${PV}.orig.tar.gz \
13            ${DEBIAN_MIRROR}/main/i/ifupdown/ifupdown_${PV}-4.8.diff.gz;patch=1 \
14            file://busybox.patch;patch=1 \
15            file://udhcpc.patch;patch=1 \
16            file://zeroconf.patch;patch=1 \
17            file://gcc34-fix.patch;patch=1 \
18            file://init \
19            file://interfaces"
20
21 EXTRA_OEMAKE = ""
22
23 do_compile () {
24         chmod a+rx *.pl *.sh
25         oe_runmake 'CC=${CC}' "CFLAGS=${CFLAGS} -Wall -W -D'IFUPDOWN_VERSION=\"${PV}\"'"
26 }
27
28 do_install () {
29         install -d ${D}${sysconfdir}/init.d \
30                    ${D}${sysconfdir}/network \
31                    ${D}${base_sbindir}
32         install -m 0755 ifup ${D}${base_sbindir}/
33         ln ${D}${base_sbindir}/ifup ${D}${base_sbindir}/ifdown
34         install -m 0644 ${WORKDIR}/init ${D}${sysconfdir}/init.d/networking
35         install -m 0644 ${WORKDIR}/interfaces ${D}${sysconfdir}/network/interfaces
36 }