]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/install/install-native_0.1.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / install / install-native_0.1.bb
1 # This package uses the GNU autotools install-sh script to implement
2 # a target-capable 'install' command.
3 DESCRIPTION = "Target install command"
4 MAINTAINER = "John Bowler <jbowler@acm.org>"
5 SECTION = "devel"
6 PRIORITY = "optional"
7 LICENSE = "MIT"
8 INHIBIT_DEFAULT_DEPS = "1"
9 PR = "r1"
10
11 SRC_URI = "file://install-sh"
12
13 PACKAGES = ""
14 S = "${WORKDIR}"
15
16 do_stage() {
17         # When the install command is executed 'STRIP' is defined correctly in
18         # the environment
19         rm -f ${STAGING_BINDIR}/install-sh
20         cp install-sh ${STAGING_BINDIR}/install-sh
21         chmod 755 ${STAGING_BINDIR}/install-sh
22         rm -f ${STAGING_BINDIR}/install
23         echo '#!/bin/sh' >${STAGING_BINDIR}/install
24         echo 'STRIPPROG="$STRIP" exec sh "${STAGING_BINDIR}/install-sh" "$@"' >>${STAGING_BINDIR}/install
25         chmod 755 ${STAGING_BINDIR}/install
26 }