]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/iperf/iperf_1.7.0.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / iperf / iperf_1.7.0.bb
1 SECTION = "console/network"
2 DESCRIPTION = "Iperf is a tool to measure maximum TCP bandwidth, allowing the tuning of various parameters and UDP characteristics"
3 HOMEPAGE = "http://dast.nlanr.net/Projects/Iperf/"
4 LICENSE = "BSD"
5 MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
6 PR = "r1"
7
8 SRC_URI = "http://dast.nlanr.net/Projects/Iperf/iperf-${PV}-source.tar.gz \
9         file://socketaddr-h-errno.diff;patch=1"
10
11 inherit autotools
12
13 S="${WORKDIR}/iperf-${PV}/cfg"
14
15 do_configure() {
16         oe_runconf
17 }
18
19 do_compile() {
20         cd ${WORKDIR}/iperf-${PV}
21         oe_runmake
22 }
23
24 do_install() {
25         cd ${WORKDIR}/iperf-${PV}/src
26         oe_runmake INSTALL_DIR=${D}${bindir} install
27 }