]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/ipkg-utils/ipkg-utils_1.6cvs.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / ipkg-utils / ipkg-utils_1.6cvs.bb
1 DESCRIPTION = "Itsy Package Manager utilities"
2 DEPENDS = ""
3 SECTION = "base"
4 PRIORITY = "optional"
5 MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
6 LICENSE = "GPL"
7 CONFLICTS = "ipkg-link"
8 RDEPENDS = "python"
9 PV_append = "${CVSDATE}"
10 PR = "r9"
11
12 SRC_URI = "${HANDHELDS_CVS};module=ipkg-utils"
13            
14 S = "${WORKDIR}/ipkg-utils"
15
16 INSTALL = "ipkg-build ipkg-deb-unbuild ipkg-unbuild ipkg-compare-versions ipkg-upload ipkg-make-index ipkg-link ipkg.py"
17
18 do_compile() {
19         oe_runmake ipkg-compare-versions
20 }
21
22 do_install() {
23         install -d ${D}${bindir}
24         for i in ${INSTALL}
25         do
26                 install -m 0755 $i ${D}${bindir}
27         done
28 }
29
30 #FIXME: ipkg-utils is not allowed to have packages or else a ipkg-native -> ipkg-utils -> ipkg-utils
31 #       recursive dependency is triggered. This has been fixed by installing the ipkg-link script in
32 #       a dedicated package.
33 #PACKAGES_prepend = "ipkg-link "
34 #FILES_ipkg-link = "${bindir}/ipkg-link"
35