]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/iputils/iputils_20020927.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / iputils / iputils_20020927.bb
1 SECTION = "console/utils"
2 BROKEN = "1"
3 DEPENDS = "docbook-utils-native"
4 DESCRIPTION = "Utilities for the IP protocol."
5 LICENSE ="BSD"
6 SRC_URI = "http://www.tux.org/pub/people/alexey-kuznetsov/ip-routing/iputils-ss020927.tar.gz"
7 S = "${WORKDIR}/iputils"
8
9 EXTRA_OEMAKE = ""
10
11 do_compile () {
12         oe_runmake 'CC=${CC}' \
13                    KERNEL_INCLUDE="${STAGING_INCDIR}" \
14                    LIBC_INCLUDE="${STAGING_INCDIR}"
15         oe_runmake -C doc 'CC=${CC}' \
16                    KERNEL_INCLUDE="${STAGING_INCDIR}" \
17                    LIBC_INCLUDE="${STAGING_INCDIR}"
18 }
19
20 do_install () {
21         install -d ${D}${base_bindir} ${D}${sbindir} \
22                    ${D}${mandir}/man8 ${D}${docdir}/${P}
23         install -m 0755 ping ${D}${base_bindir}/
24         for f in ipg tracepath clockdiff rdisc arping \
25                 tftpd rarpd tracepath6 traceroute6 ping6; do
26                 install -m 0755 $f ${D}${sbindir}/
27         done
28         install -m 0644 doc/*.8 ${D}${mandir}/man8/
29         install -m 0644 doc/*.html ${D}${docdir}/${P}/
30 }