]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/iqnotes/iqnotes_2.0.2.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / iqnotes / iqnotes_2.0.2.bb
1 DESCRIPTION = "IQNotes is notes kept in a hierarchical(tree like) manner. \
2 It handles todo, events, sketching. It can acts as a contact, password, \
3 credit card manager and even more, because is highly configurable. \
4 Data can be crypted by strong AES algorithm."
5 SECTION = "opie/applications"
6 PRIORITY = "optional"
7 LICENSE = "GPL"
8 DEPENDS = "virtual/libqpe"
9 HOMEPAGE = "http://iqnotes.kybu.org"
10 AUTHOR = "Peter Vrabel <kybu@kybu.org>"
11 PR = "r3"
12
13 SRC_URI = "http://www.vanille.de/mirror/iqnotes-2.0.2-src.tar.bz2 \
14            file://md5.diff;patch=1 \
15            file://qt2310-fontbug.patch;patch=1"
16
17 S = "${WORKDIR}/iqnotes/iqnotes"
18
19 inherit palmtop
20
21 QMAKE_PROFILES = "iqnotes.pro"
22 export OE_QMAKE_LINK="${CXX}"
23
24
25 do_install() {
26         install -d ${D}${palmtopdir}/help/html \
27                    ${D}${palmtopdir}/bin \
28                    ${D}${palmtopdir}/apps/Applications \
29                    ${D}${palmtopdir}/pics/iqnotes/items \
30                    ${D}${palmtopdir}/iqnotes/icons
31         install -m 0755 ${S}/../bin/iqnotes ${D}${palmtopdir}/bin/
32         install -m 0644 ${S}/../apps/Applications/*.desktop ${D}${palmtopdir}/apps/Applications/
33         install -m 0644 ${S}/../pics/iqnotes/*.png ${D}${palmtopdir}/pics/iqnotes/
34         install -m 0644 ${S}/../help/html/iqnotes.html ${D}${palmtopdir}/help/html/
35         install -m 0644 ${S}/../pics/*.xpm ${D}${palmtopdir}/pics/
36 }