]> pilppa.org Git - familiar-h63xx-build.git/blob - org.handhelds.familiar/packages/irda-utils/irda-utils_0.9.16.bb
OE tree imported from monotone branch org.openembedded.oz354fam083 at revision 8b12e3...
[familiar-h63xx-build.git] / org.handhelds.familiar / packages / irda-utils / irda-utils_0.9.16.bb
1 DESCRIPTION = "Provides common files needed to use IrDA. \
2 IrDA allows communication over Infrared with other devices \
3 such as phones and laptops."
4 SECTION = "base"
5 LICENSE = "GPL"
6 PR = "r4"
7
8 SRC_URI = "${SOURCEFORGE_MIRROR}/irda/irda-utils-${PV}.tar.gz \
9            file://configure.patch;patch=1 \
10            file://m4.patch;patch=1 \
11            file://init"
12
13 export SYS_INCLUDES="-I${STAGING_INCDIR}"
14
15 inherit autotools update-rc.d
16
17 INITSCRIPT_NAME = "irattach"
18 INITSCRIPT_PARAMS = "defaults 20"
19
20 do_compile () {
21         oe_runmake -e -C irattach
22         oe_runmake -e -C irdaping
23 }
24
25 do_install () {
26         install -d ${D}${sbindir}
27         oe_runmake -C irattach ROOT="${D}" install
28         oe_runmake -C irdaping ROOT="${D}" install
29
30         install -d ${D}${sysconfdir}/init.d
31         install -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/irattach
32 }
33